$re = '/^#!(/usr)?/bin/(env )?(ba)?sh$/m';
$str = '#!/bin/sh
#!/bin/bash
#!/usr/bin/env bash
#!/usr/bin/env sh
#!/usr/bin/env python
#!/usr/bin/env python3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);