const regex = new RegExp('^#!(/usr)?/bin/(env )?(ba)?sh$', 'gm')
const str = `#!/bin/sh
#!/bin/bash
#!/usr/bin/env bash
#!/usr/bin/env sh
#!/usr/bin/env python
#!/usr/bin/env python3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}