re = /^(409[0-6]|(40[0-8]|[1-3]\d\d|[1-9]\d|[1-9])\d|[1-9])$/m
str = '0
1
5
10
15
25
35
100
105
125
135
200
205
235
255
256
529
935
1000
2135
3255
4000
4085
4095
4096
4100
5000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end