#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(409[0-6]|(40[0-8]|[1-3]\d\d|[1-9]\d|[1-9])\d|[1-9])$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"5" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"25" & @CRLF & _
"35" & @CRLF & _
"100" & @CRLF & _
"105" & @CRLF & _
"125" & @CRLF & _
"135" & @CRLF & _
"200" & @CRLF & _
"205" & @CRLF & _
"235" & @CRLF & _
"255" & @CRLF & _
"256" & @CRLF & _
"529" & @CRLF & _
"935" & @CRLF & _
"1000" & @CRLF & _
"2135" & @CRLF & _
"3255" & @CRLF & _
"4000" & @CRLF & _
"4085" & @CRLF & _
"4095" & @CRLF & _
"4096" & @CRLF & _
"4100" & @CRLF & _
"5000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")