import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(409[0-6]|(40[0-8]|[1-3]\\d\\d|[1-9]\\d|[1-9])\\d|[1-9])$";
final String string = "0\n"
+ "1\n"
+ "5\n"
+ "10\n"
+ "15\n"
+ "25\n"
+ "35\n"
+ "100\n"
+ "105\n"
+ "125\n"
+ "135\n"
+ "200\n"
+ "205\n"
+ "235\n"
+ "255\n"
+ "256\n"
+ "529\n"
+ "935\n"
+ "1000\n"
+ "2135\n"
+ "3255\n"
+ "4000\n"
+ "4085\n"
+ "4095\n"
+ "4096\n"
+ "4100\n"
+ "5000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}