const regex = new RegExp('^(409[0-6]|(40[0-8]|[1-3]\\d\\d|[1-9]\\d|[1-9])\\d|[1-9])$', 'gm')
const str = `0
1
5
10
15
25
35
100
105
125
135
200
205
235
255
256
529
935
1000
2135
3255
4000
4085
4095
4096
4100
5000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}