# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:INSERT_|UPDATE_)?([NY|80]{2}[0-9]{6})_([^0-9]*)_([0-9]{4})_06_30\.(?:txt|csv)"
test_str = ("UPDATE_80070175_LOCATION_MARKING_PERIOD_2020_06_30.txt\n"
"INSERT_80070175_STUDENT_CLASS_GRADE_DETAIL_2020_06_30.txt\n"
"INSERT_80070175_STUDENT_CLASS_ENTRY_EXIT_2020_06_30.txt\n"
"INSERT_80070175_STUD_ATTEND_DAY_2020_06_30.txt\n"
"INSERT_80070175_PROGRAMS_FACT_2020_06_30.txt\n"
"INSERT_80070175_DAY_CALENDAR_2020_06_30.txt\n"
"INSERT_80070175_CRSE_INSTRUCT_ASSIGNMENT_2020_06_30.txt\n"
"INSERT_80070175_COURSE_2020_06_30.txt\n"
"INSERT_80070175_ATTENDANCE_CODES_2020_06_30.txt\n"
"80070175_STUDENT_LITE_UPDATE_2020_06_30.txt\n"
"80070175_SCHOOL_ENTRY_EXIT_INSERT_2020_06_30.txt\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.