use strict;
my $str = 'UPDATE_80070175_LOCATION_MARKING_PERIOD_2020_06_30.txt
INSERT_80070175_STUDENT_CLASS_GRADE_DETAIL_2020_06_30.txt
INSERT_80070175_STUDENT_CLASS_ENTRY_EXIT_2020_06_30.txt
INSERT_80070175_STUD_ATTEND_DAY_2020_06_30.txt
INSERT_80070175_PROGRAMS_FACT_2020_06_30.txt
INSERT_80070175_DAY_CALENDAR_2020_06_30.txt
INSERT_80070175_CRSE_INSTRUCT_ASSIGNMENT_2020_06_30.txt
INSERT_80070175_COURSE_2020_06_30.txt
INSERT_80070175_ATTENDANCE_CODES_2020_06_30.txt
80070175_STUDENT_LITE_UPDATE_2020_06_30.txt
80070175_SCHOOL_ENTRY_EXIT_INSERT_2020_06_30.txt
';
my $regex = qr/(?:INSERT_|UPDATE_)?([NY|80]{2}[0-9]{6})_([^0-9]*)_([0-9]{4})_06_30\.(?:txt|csv)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}