#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:INSERT_|UPDATE_)?([NY|80]{2}[0-9]{6})_([^0-9]*)_([0-9]{4})_06_30\.(?:txt|csv)"
Local $sString = "UPDATE_80070175_LOCATION_MARKING_PERIOD_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_STUDENT_CLASS_GRADE_DETAIL_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_STUDENT_CLASS_ENTRY_EXIT_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_STUD_ATTEND_DAY_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_PROGRAMS_FACT_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_DAY_CALENDAR_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_CRSE_INSTRUCT_ASSIGNMENT_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_COURSE_2020_06_30.txt" & @CRLF & _
"INSERT_80070175_ATTENDANCE_CODES_2020_06_30.txt" & @CRLF & _
"80070175_STUDENT_LITE_UPDATE_2020_06_30.txt" & @CRLF & _
"80070175_SCHOOL_ENTRY_EXIT_INSERT_2020_06_30.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")