import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:INSERT_|UPDATE_)?([NY|80]{2}[0-9]{6})_([^0-9]*)_([0-9]{4})_06_30\\.(?:txt|csv)";
final String string = "UPDATE_80070175_LOCATION_MARKING_PERIOD_2020_06_30.txt\n"
+ "INSERT_80070175_STUDENT_CLASS_GRADE_DETAIL_2020_06_30.txt\n"
+ "INSERT_80070175_STUDENT_CLASS_ENTRY_EXIT_2020_06_30.txt\n"
+ "INSERT_80070175_STUD_ATTEND_DAY_2020_06_30.txt\n"
+ "INSERT_80070175_PROGRAMS_FACT_2020_06_30.txt\n"
+ "INSERT_80070175_DAY_CALENDAR_2020_06_30.txt\n"
+ "INSERT_80070175_CRSE_INSTRUCT_ASSIGNMENT_2020_06_30.txt\n"
+ "INSERT_80070175_COURSE_2020_06_30.txt\n"
+ "INSERT_80070175_ATTENDANCE_CODES_2020_06_30.txt\n"
+ "80070175_STUDENT_LITE_UPDATE_2020_06_30.txt\n"
+ "80070175_SCHOOL_ENTRY_EXIT_INSERT_2020_06_30.txt\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}