re = /(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])/mi
str = 'лох плох ппп лох лоох ллох л о х
лох
плох
ппп
лох
лоох
ллох лох лохло х лохло хлам
л о х
л оо х
лоох
лox
лооx
ло оох
плохо
неплохо
лохотрон
блоха
заглох
он оглох от взыва
он лоооох меня
он л-ох меня
он лОх меня
тыЛОХчего
металлохимия
маслохранилище
мой лохматый друг
лох'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end