const regex = /(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=.(?:[\\s])))([л]+[\\s-]*[о]+[\\s-]*[х]+)+(?:$|[\\s-])', 'gmiu')
const str = `лох плох ппп лох лоох ллох л о х
лох
плох
ппп
лох
лоох
ллох лох лохло х лохло хлам
л о х
л оо х
лоох
лox
лооx
лооох
плохо
неплохо
лохотрон
блоха
заглох
он оглох от взыва
он лоооох меня
он л-ох меня
он лОх меня
тыЛОХчего
металлохимия
маслохранилище
мой лохматый друг
лох`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}