using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])";
string input = @"лох плох ппп лох лоох ллох л о х
лох
плох
ппп
лох
лоох
ллох лох лохло х лохло хлам
л о х
л оо х
лоох
лox
лооx
лооох
плохо
неплохо
лохотрон
блоха
заглох
он оглох от взыва
он лоооох меня
он л-ох меня
он лОх меня
тыЛОХчего
металлохимия
маслохранилище
мой лохматый друг
лох";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}