#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)(?:^|(?<=.(?:[\s])))([л]+[\s-]*[о]+[\s-]*[х]+)+(?:$|[\s-])"
Local $sString = "лох плох ппп лох лоох ллох л о х " & @CRLF & _
"лох" & @CRLF & _
"плох" & @CRLF & _
"ппп" & @CRLF & _
"лох" & @CRLF & _
"лоох" & @CRLF & _
"ллох лох лохло х лохло хлам" & @CRLF & _
"л о х" & @CRLF & _
"л оо х" & @CRLF & _
"лоох" & @CRLF & _
"лox" & @CRLF & _
"лооx" & @CRLF & _
"лооох" & @CRLF & _
"плохо" & @CRLF & _
"неплохо" & @CRLF & _
"лохотрон" & @CRLF & _
"блоха" & @CRLF & _
"заглох " & @CRLF & _
"он оглох от взыва" & @CRLF & _
"он лоооох меня" & @CRLF & _
"он л-ох меня" & @CRLF & _
"он лОх меня" & @CRLF & _
"тыЛОХчего" & @CRLF & _
"металлохимия" & @CRLF & _
"маслохранилище" & @CRLF & _
"мой лохматый друг" & @CRLF & _
"лох"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")