// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9_-]+)[\/]*[\?\=a-zA-Z0-9_-]*$").unwrap();
let string = "www.mysite.com/foo/bar/
www.mysite.com/foo/bar/?u=90
www.mysite.com/foo/bar/mmm-nnn/?u=preview
www.mysite.com/foo/bar/ppp
www.mysite.com/foo/bar/?sd=100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}