$re = '/([a-zA-Z0-9_-]+)[\/]*[\?\=a-zA-Z0-9_-]*$/m';
$str = 'www.mysite.com/foo/bar/
www.mysite.com/foo/bar/?u=90
www.mysite.com/foo/bar/mmm-nnn/?u=preview
www.mysite.com/foo/bar/ppp
www.mysite.com/foo/bar/?sd=100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);