#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9_-]+)[\/]*[\?\=a-zA-Z0-9_-]*$"
Local $sString = "www.mysite.com/foo/bar/" & @CRLF & _
"" & @CRLF & _
"www.mysite.com/foo/bar/?u=90" & @CRLF & _
"" & @CRLF & _
"www.mysite.com/foo/bar/mmm-nnn/?u=preview" & @CRLF & _
"www.mysite.com/foo/bar/ppp" & @CRLF & _
"www.mysite.com/foo/bar/?sd=100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")