import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_-]+)[\\/]*[\\?\\=a-zA-Z0-9_-]*$";
final String string = "www.mysite.com/foo/bar/\n\n"
+ "www.mysite.com/foo/bar/?u=90\n\n"
+ "www.mysite.com/foo/bar/mmm-nnn/?u=preview\n"
+ "www.mysite.com/foo/bar/ppp\n"
+ "www.mysite.com/foo/bar/?sd=100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}