re = /{\"hiRes\":\"(http.:.*?.jpg)\"/m
str = '{"hiRes":"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UL1500_.jpg"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end