package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){\"hiRes\":\"(http.:.*?.jpg)\"`)
var str = `{"hiRes":"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UL1500_.jpg"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}