using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\""hiRes\"":\""(http.:.*?.jpg)\""";
string input = @"{""hiRes"":""https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UL1500_.jpg""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}