$re = '/{\"hiRes\":\"(http.:.*?.jpg)\"/m';
$str = '{"hiRes":"https://images-na.ssl-images-amazon.com/images/I/71rUs2a23JL._UL1500_.jpg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);