// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(400022|642398|400023)\d{10}$").unwrap();
let string = "4000227890123456
6423987890123456
4000237890123456
4000247890123456
400023890123456
40002378901234564";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}