const regex = /^(400022|642398|400023)\d{10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(400022|642398|400023)\\d{10}$', 'gm')
const str = `4000227890123456
6423987890123456
4000237890123456
4000247890123456
400023890123456
40002378901234564`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}