$re = '/^(400022|642398|400023)\d{10}$/m';
$str = '4000227890123456
6423987890123456
4000237890123456
4000247890123456
400023890123456
40002378901234564';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);