#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(400022|642398|400023)\d{10}$"
Local $sString = "4000227890123456" & @CRLF & _
"6423987890123456" & @CRLF & _
"4000237890123456" & @CRLF & _
"4000247890123456" & @CRLF & _
"400023890123456" & @CRLF & _
"40002378901234564"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")