import Foundation
let pattern = #"(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/test.txt
test.txt
C:\test.txt
D:\test\test2.txt
asdfasdf
abcd :Dasdfrew
hbkj23j;nlkfsld khjasdf
adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs
test/test.txt
C:/test.txt
C:\test/test.txt
C:\/test.txt
C:/\test.txt
aa:\
C:\\test.txt
C:/\test.txt
\test.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)