#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)"
Local $sString = "/test.txt" & @CRLF & _
"test.txt" & @CRLF & _
"C:\test.txt" & @CRLF & _
"D:\test\test2.txt" & @CRLF & _
" asdfasdf " & @CRLF & _
"abcd :Dasdfrew" & @CRLF & _
"hbkj23j;nlkfsld khjasdf" & @CRLF & _
"adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs" & @CRLF & _
"test/test.txt" & @CRLF & _
"C:/test.txt" & @CRLF & _
"C:\test/test.txt" & @CRLF & _
"C:\/test.txt" & @CRLF & _
"C:/\test.txt" & @CRLF & _
"aa:\" & @CRLF & _
"C:\\test.txt" & @CRLF & _
"C:/\test.txt" & @CRLF & _
"\test.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")