re = /(([a-zA-Z]:[\/\\]|\\\\)([0-9a-zA-Z_\-. ]+[\/\\]?)*)|([0-9a-zA-Z_\-\\\/.][0-9a-zA-Z_\-\\\/. ]*)|(^$)/
str = '/test.txt
test.txt
C:\\test.txt
D:\\test\\test2.txt
asdfasdf
abcd :Dasdfrew
hbkj23j;nlkfsld khjasdf
adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r\'l;,qwetfs
test/test.txt
C:/test.txt
C:\\test/test.txt
C:\\/test.txt
C:/\\test.txt
aa:\\
C:\\\\test.txt
C:/\\test.txt
\\test.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end