const regex = /(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([a-zA-Z]:[\/\\\\]|\\\\\\\\)([0-9a-zA-Z_\\-. ]+[\/\\\\]?)*)|([0-9a-zA-Z_\\-\\\\\/.][0-9a-zA-Z_\\-\\\\\/. ]*)|(^$)', 'g')
const str = `/test.txt
test.txt
C:\\test.txt
D:\\test\\test2.txt
asdfasdf
abcd :Dasdfrew
hbkj23j;nlkfsld khjasdf
adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs
test/test.txt
C:/test.txt
C:\\test/test.txt
C:\\/test.txt
C:/\\test.txt
aa:\\
C:\\\\test.txt
C:/\\test.txt
\\test.txt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}