import Foundation
let pattern = #"hasAccess\((?:[^,]+,){2}[^()]+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
STRING("safsf", "asf", "asf")
STRING("safsf", "asf")
hasAccess("bs", $this->method(), "b3")
STRING("safsf", "asf", "asf","more)
hasAccess("bs","bs2","b3")
hasAccess("bs","bs2()","b3")
hasAccess("bs2","bs2()", what)
hasA,a,a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)