#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)hasAccess\((?:[^,]+,){2}[^()]+\)"
Local $sString = "STRING("safsf", "asf", "asf")" & @CRLF & _
"STRING("safsf", "asf")" & @CRLF & _
"hasAccess("bs", $this->method(), "b3")" & @CRLF & _
"STRING("safsf", "asf", "asf","more)" & @CRLF & _
"hasAccess("bs","bs2","b3")" & @CRLF & _
"hasAccess("bs","bs2()","b3")" & @CRLF & _
"hasAccess("bs2","bs2()", what)" & @CRLF & _
"hasA,a,a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")