$re = '/hasAccess\((?:[^,]+,){2}[^()]+\)/m';
$str = 'STRING("safsf", "asf", "asf")
STRING("safsf", "asf")
hasAccess("bs", $this->method(), "b3")
STRING("safsf", "asf", "asf","more)
hasAccess("bs","bs2","b3")
hasAccess("bs","bs2()","b3")
hasAccess("bs2","bs2()", what)
hasA,a,a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);