const regex = /hasAccess\((?:[^,]+,){2}[^()]+\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hasAccess\\((?:[^,]+,){2}[^()]+\\)', 'gm')
const str = `STRING("safsf", "asf", "asf")
STRING("safsf", "asf")
hasAccess("bs", \$this->method(), "b3")
STRING("safsf", "asf", "asf","more)
hasAccess("bs","bs2","b3")
hasAccess("bs","bs2()","b3")
hasAccess("bs2","bs2()", what)
hasA,a,a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}