use strict;
my $str = '000000,"NAMPUNG-NI 66 KV TAP SONGCHO"ON",';
my $regex = qr/(?<!")((?>[\w- ]+))(?!")/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";