re = /(http|https)\:\/\/(?:(.+?)(?:\:(.+?))?\@)?((?:[\w-]+\.)+)([A-Za-z0-9]+)(?:\:(\d{2,5}))?((?:\/[\w-%.]*)+)?(\?(?:[\w-%&="'+,]+)?)?(\#(?:[^#]+)?)?/
str = 'http://username:password@sub.domain.name:443/pathabc?query="abc"#fragment'
# Print the match result
str.match(re) do |match|
puts match.to_s
end