$re = '/(http|https)\:\/\/(?:(.+?)(?:\:(.+?))?\@)?((?:[\w-]+\.)+)([A-Za-z0-9]+)(?:\:(\d{2,5}))?((?:\/[\w-%.]*)+)?(\?(?:[\w-%&="\'+,]+)?)?(\#(?:[^#]+)?)?/';
$str = 'http://username:password@sub.domain.name:443/pathabc?query="abc"#fragment';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);