package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http|https)\:\/\/(?:(.+?)(?:\:(.+?))?\@)?((?:[\w-]+\.)+)([A-Za-z0-9]+)(?:\:(\d{2,5}))?((?:\/[\w-%.]*)+)?(\?(?:[\w-%&="'+,]+)?)?(\#(?:[^#]+)?)?`)
var str = `http://username:password@sub.domain.name:443/pathabc?query="abc"#fragment`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}