const regex = /(http|https)\:\/\/(?:(.+?)(?:\:(.+?))?\@)?((?:[\w-]+\.)+)([A-Za-z0-9]+)(?:\:(\d{2,5}))?((?:\/[\w-%.]*)+)?(\?(?:[\w-%&="'+,]+)?)?(\#(?:[^#]+)?)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https)\\:\\\/\\\/(?:(.+?)(?:\\:(.+?))?\\@)?((?:[\\w-]+\\.)+)([A-Za-z0-9]+)(?:\\:(\\d{2,5}))?((?:\\\/[\\w-%.]*)+)?(\\?(?:[\\w-%&="\'+,]+)?)?(\\#(?:[^#]+)?)?', '')
const str = `http://username:password@sub.domain.name:443/pathabc?query="abc"#fragment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}