import Foundation
let pattern = #"\d+(\.\d+)?([Ee]\D+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is just a test
where we can have multiple email addresses
which can be gil@home.com
g.echeverria@tec.mx
gil2@one.long.domain.org
Or something more elaborate
one1.two2-three3@is.this-site.real.net
brave_world@survive.com.it
And just like that there can me more formats for emails
But how can we extract those
34.76e4
875
34.43.34.676
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)