const regex = /\d+(\.\d+)?([Ee]\D+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(\\.\\d+)?([Ee]\\D+)?', 'gm')
const str = `This is just a test
where we can have multiple email addresses
which can be gil@home.com
g.echeverria@tec.mx
gil2@one.long.domain.org
Or something more elaborate
one1.two2-three3@is.this-site.real.net
brave_world@survive.com.it
And just like that there can me more formats for emails
But how can we extract those
34.76e4
875
34.43.34.676`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}