// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(\.\d+)?([Ee]\D+)?").unwrap();
let string = "This is just a test
where we can have multiple email addresses
which can be gil@home.com
g.echeverria@tec.mx
gil2@one.long.domain.org
Or something more elaborate
one1.two2-three3@is.this-site.real.net
brave_world@survive.com.it
And just like that there can me more formats for emails
But how can we extract those
34.76e4
875
34.43.34.676";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}