package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(\.\d+)?([Ee]\D+)?`)
var str = `This is just a test
where we can have multiple email addresses
which can be gil@home.com
g.echeverria@tec.mx
gil2@one.long.domain.org
Or something more elaborate
one1.two2-three3@is.this-site.real.net
brave_world@survive.com.it
And just like that there can me more formats for emails
But how can we extract those
34.76e4
875
34.43.34.676`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}