// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)").unwrap();
let string = "abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}