re = /(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)/
str = 'abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end