package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)`)
var str = `abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}