$re = '/(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)/';
$str = 'abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);