re = /^(!?){0}([+]){1}([998]){3}\s([7-9]){1}([0-9]){1}\s([0-9]){3}\s([0-9]){2}\s([0-9]){2}$/m
str = '+998 99 477 55 55
998 33 665 55 55
+997 66 123 12 12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end