use strict;
my $str = '+998 99 477 55 55
998 33 665 55 55
+997 66 123 12 12';
my $regex = qr/^(!?){0}([+]){1}([998]){3}\s([7-9]){1}([0-9]){1}\s([0-9]){3}\s([0-9]){2}\s([0-9]){2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}