package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(!?){0}([+]){1}([998]){3}\s([7-9]){1}([0-9]){1}\s([0-9]){3}\s([0-9]){2}\s([0-9]){2}$`)
var str = `+998 99 477 55 55
998 33 665 55 55
+997 66 123 12 12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}